frappy/installer/frappy-gui.spec
Markus Zolliker da15df076a fetched mlz version
- before some chamges in the gerrit pipline

Change-Id: I33eb2d75f83345a7039d0fb709e66defefb1c3e0
2023-05-02 15:25:11 +02:00

34 lines
910 B
Python

# -*- mode: python -*-
import sys
from os import path
sys.path.insert(0, path.abspath('.'))
from utils import rootdir, find_uis, find_modules
binscript = path.join(rootdir, 'bin', 'frappy-gui')
a = Analysis([binscript],
pathex=[rootdir],
binaries=[],
datas=find_uis() + [
(path.join(rootdir, 'frappy', 'RELEASE-VERSION'), 'frappy')],
hiddenimports=find_modules('frappy', 'gui'),
hookspath=[],
excludes=['matplotlib'],
win_no_prefer_redirects=False,
win_private_assemblies=False,
cipher=None)
pyz = PYZ(a.pure, a.zipped_data, cipher=None)
exe = EXE(pyz,
a.scripts,
a.binaries,
a.zipfiles,
a.datas,
name='frappy-gui',
strip=False,
debug=False,
console=False)